PPE4ALL - GoFundMe Charity Page down – Incident details

Website experiencing major outage

GoFundMe Charity Page down

Resolved
Major outage
Started over 3 years agoLasted 18 minutes

Affected

Internal Systems

Major outage from 10:10 PM to 10:29 PM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We are currently investigating this incident.